Написать программу которая будет переводить биты в килобайты и наоборот ​

timtim5 timtim5    1   26.04.2020 07:49    1

Ответы
plahowajana plahowajana  13.10.2020 21:27

#include <iostream>

using namespace std;

int main()

{

   float a;

   int b;

   double  c;

   cout<<"Choose mode: 1 - KB to bit, 2 - bit to KB :";

   cin>>b;

   switch(b)

   {

   case 1:

   cout<<"Enter KByte count :"; cin>>a;

   c = a * 8 * 1024;  

   cout <<a<<" KByte = "<<c<<" bit";

   break;

   

   case 2:

   cout<<"Enter bit count :"; cin>>a;

   c = a /1024/8;  

   cout <<a<<" bit= "<<c<<" KByte";    

   break;

   }

   return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика