Написать программу для вычисления n-ой степени числа a (an). протестировать программу для а) a=3 и n=4, б) a=2 и n=5.

BeNetCat BeNetCat    1   18.05.2019 06:30    5

Ответы
АртёмПлотников АртёмПлотников  11.06.2020 12:50

Program zadacha;

var a,n,i:integer;

Begin

read(a,n);

for i:=1 to n do

      a:=a*a;

writeln(a);

end.

 

или как вариант

 

Program zadacha;

var a,n:integer;

Begin

read(a,n);

x:=exp(ln(a)*n);

writeln(x);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика