Написать программу для решения следующей : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента. если все элементы последовательности неотрицательны, то вывести ноль. program lab5_5; const n=10; type x=array[1..n] of integer; var a: x; i: integer; k: integer; begin for i: =1 to n do begin a[i]: =-10+random (91); write (a[i]: 4) end; writeln; k: =0; for i: =n downto 1 do if a[i]< 0 then begin k: =i end; if k> 0 then writeln (‘индекс отрицательного элемента=’,k: 1) else writeln (‘в массиве нет отрицательных элементов’); readln; end. как сделать эту программу без random чтоб работало в pascal abc?

1castiel03 1castiel03    2   08.07.2019 03:00    7

Ответы
ruslankasaev ruslankasaev  31.07.2020 07:30
Program lab5_5;
const n=10;
type x=array[1..n]
of integer;
var a:x;i,k:integer;
begin
for i:=1 to n do
begin
read(a[i]); {с вашего позволения я убрал "write (A[i]:4)" в остальном программа получает от пользователя 10 чисел и обрабатывает их}
end;
writeln;
k:=0;
for i:=n downto 1 do
if a[i]<0 then
begin
k:=I
end;
if k>0 then
writeln ('Индекс отрицательного элемента=',k:1)
else
writeln ('В массиве нет отрицательных элементов');
readln;
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика