Надо решить двумерным массивом! даны два числа n и m. создайте двумерный массив a[n][m], заполните его таблицей умножения a[i][j]=i*j и выведите на экран. при этом нельзя использовать вложенные циклы, все заполнение массива должно производиться одним циклом. входные данные программа получает на вход два числа n и m – количество строк и столбцов, соответственно. выходные данные программа должна вывести полученный массив. числа разделяйте одним пробелом. примеры входные данные 3 3 выходные данные 0 0 0 0 1 2 0 2 4

aleksа005005 aleksа005005    1   27.08.2019 03:20    4

Ответы
mariana122 mariana122  05.10.2020 22:02
Var
   A:array[0..100,0..100] of integer;
   i,N,M:integer;
Begin
ReadLn(N,M);
For i:= 0 to N*M-1 do
    Begin
    A[i div N, i mod M]:=(i div N)*(i mod M);
    Write(A[i div N, i mod M],' ')
    End
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика