Моделирование однострочного редактора. паскаль авс на вход программе подается строка и команда удаления del i n, где i – номер символа в строке, начиная с которого надо удалить n символов. требуется удалить из данной строки n символов, начиная с i-го. например, для строки my old name was thom команда del 4 3 к удалению слова old: my name was thom.

77linnik 77linnik    3   13.07.2019 18:20    3

Ответы
PolinaCartonova PolinaCartonova  25.08.2020 07:57
// PascalABC.NET 3.0, сборка 1111
begin
  var s:=ReadLnString('Введите строку: ');
  var a:=ReadLnString('Введите команду: ').ToWords;
  Delete(s,StrToInt(a[1]),StrToInt(a[2]));
  Writeln('Результат: '+s)
end.

Тестовое решение:
Введите строку: my old name was Thom
Введите команду: DEL 4 3
Результат: my  name was Thom
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика