На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран. формат входных данных входной поток содержит целое число x (1000≤x≤9999) формат выходных данных выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.

alinasastun0 alinasastun0    3   17.08.2019 20:50    7

Ответы
alena3211 alena3211  26.08.2020 06:05
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a, cout << "\n";
    b = a/1000;
    cout << b << "\n";
    b = a/100 % 10;
    cout << b << "\n";
    b = a % 100 / 10;
    cout << b << "\n";
    b = a % 10;
    cout << b << "\n";
    return 0;
}

Пример:
a = 7052
7
0
5
2
На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и вы
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика