tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив к из 15 целых случайных
Дан массив к из 15 целых случайных чисел из интервала [0,50]. найти в массиве: к5 – количество чисел, кратных 5, к3 – количество чисел, кратных 3.
alyona20107
1 30.11.2019 16:46
4
Ответы
Пакмен007
10.10.2020 17:26
Const n=15;
var
k: array [1..n] of integer;
i,k5,k3: integer;
begin
k5:=0; k3:=0;
for i:=1 to n do
a[i]:=random(51);
for i:=1 to n do begin
if a[i] mod 5=0 then inc(k5);
if a[i] mod 3=0 then inc(k3);
end;
writeln;
writeln(k3, ' ', k5);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Ataka4
31.07.2019 00:40
Составить программу на каком-либо языке программирования (указать версию языка) или алгоритмическом языке. (паскаль) на вход программе , полученные каждым учеником на егэ по информатике,...
epometid
31.07.2019 00:40
нужно до завтра это сделать. просто умоляю. написать программу находящую произведение следующей последовательности: p = 1/9 + 1/18 + 1/27 + + 1/162...
nikitamany87
31.07.2019 00:40
Іі. цикли 1. знайти найменший дільник натурального числа. 2. знайти всі дільники натурального числа. 3. знайти найбільший дільник натурального числа. 4. знайти суму дільників...
blackytwhite
31.07.2019 00:40
Переведите с точностью до 5 знаков после запятой десятичное число 27,27(10) в двоичную, восьмеричную и шестнадцатеричную систему....
кирик74
31.07.2019 00:40
Из 110 приехавших туристов 75 знали испанский язык и 87 знали язык. 7 человек не знали ни испанского, ни . сколько туристов знали оба этих языка? ответ:...
Arturkim04
31.07.2019 00:40
Яка різниця між назвою файлу бд і назвою таблиці цієї бд?...
2003lyuba
31.07.2019 00:40
Написать программу ввода числовых данных в одномерный массив, обработки этого массива и вывода результата. в массиве из 10 целых чисел каждое нечетное число обнулить. сделать...
yasuper07p0ad9l
31.07.2019 00:40
Нужно составить алгоритм по информатике - если ты застрял в лифте -если ты заблудился в лесу...
art171
31.07.2019 00:50
Составьте таблицу истинности для (a & b) v (¬a & ¬b)?...
Pandochkalove7
31.07.2019 00:50
Если y – вещественная переменная, а n – целая, то какие из следующих операторов присваивания правильные, а какие нет? что из них истинно или ложно? y: = n+1 n: =y-1 n: =0.4 y:...
Популярные вопросы
1)это морское сражение стало победным для российского флота. все нижние чины...
2
1)что стало следствием великого посольства петра 1? а)азовские походы б)перепись...
1
Кполитике разрядки 1970х гг. относится: а) договор между и фрг о признании...
1
Какой ветер господствует в пустынях в субтропиках...
2
Автомобиль, скорость которого составляет 72 км/ч, тормозит через 4 секунды....
3
На одном чертеже постройте графики функции: y = 3x , y = -2x+2 , y = 5...
1
Ω(c)=52,17% ω(н)=13.05% ω(о)=34,78% dh2(cx hy oz)=23 найти формулу вещества...
3
Найдите число, обратное: 1)сумме чисел 3/4 и 1/4; разность чисел 2целых 3/4...
2
Что едят канадцы на завтрак обед и ужин...
2
Найдите значение выражения корень из 64- корень из 36: корень из 4...
2
var
k: array [1..n] of integer;
i,k5,k3: integer;
begin
k5:=0; k3:=0;
for i:=1 to n do
a[i]:=random(51);
for i:=1 to n do begin
if a[i] mod 5=0 then inc(k5);
if a[i] mod 3=0 then inc(k3);
end;
writeln;
writeln(k3, ' ', k5);
end.