Дан двумерный массив. проверить, есть ли в нем одинаковые элементы. , , написать программу в паскале

даниил853 даниил853    3   22.07.2019 13:10    4

Ответы
stupidgirl3 stupidgirl3  03.10.2020 10:43
Program arr;
Const n=3;
var i, j, tmp, k, z:integer;
    c:boolean;
    a:array [1..n,1..n] of integer;

begin
c:=false;
for i:=1 to n do
  for j:=1 to n do
    read(a[i][j]);
for i:=1 to n do
  for j:=1 to n do
    begin
    tmp:=a[i][j];
    for k:=i+1 to n do
      for z:=j+1 to n do
        if tmp = a[k][z] then
        c:=true;
    end;
writeln;
for i:=1 to n do
begin
  for j:=1 to n do
    write(a[i][j], ' ');
  writeln;
end;
if c = true then
  writeln('В данном массиве есть равные друг другу элементы')
  else writeln('Элементы, равные друг другу, отсутсвуют в данном массиве');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика