tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Cоставьте программу уменьшения
Cоставьте программу уменьшения значения всех элементов массива на 4
Прост2004
3 18.09.2019 19:40
6
Ответы
АндрейПермь123
08.10.2020 00:40
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Transform(t->t-4); a.Println
end.
Пример
n= 13
-42 -19 36 37 -26 -28 12 12 40 50 24 -8 5
-46 -23 32 33 -30 -32 8 8 36 46 20 -12 1
ПОКАЗАТЬ ОТВЕТЫ
monyachina1081p08tm7
08.10.2020 00:40
Program MASSX;
var
mass : array [0..10] of integer;
i, b : integer;
begin
b := 10;
randomize;
for i := 1 to b do
begin
mass[i] := random(10, 110);
mass[i] := mass[i] - 4;
writeln(mass[i]);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Pomogite20000p
16.03.2020 21:29
После переустановки Виндоус 7 на ноутбуке не роботает звук все драйвера установлены Если нужна связь мой дискорд aniNiash#2766...
daniilfd
16.03.2020 21:35
Можно ли присваивать программам имена зарезервированных языком программирования слов (begin, end, program)...
илья5310
16.03.2020 21:36
Для хранения растрового изображения размером 1024х512 пикселей отвели 256 Кбайт памяти. Какой размер 1 пикселя?...
evgeniya64
16.03.2020 21:40
Написать программу по вычислению 7!, используя цикл с предусловием(1) и использую цикл с параметром (2)...
Joom372
16.03.2020 21:41
Постройте таблицу истинности!...
paninvla2018
16.03.2020 21:43
Чему равен B[9]? for i:= 1 to 10B [i]= i*4-3...
Pepsi34
16.03.2020 21:48
Напиши за база данных MS Access): записи, в которых названия стран заканчиваются на овна ....
DementоR
16.03.2020 21:48
Написать программу по вычислению квадрата любого числа от 0-9, используя цикл с предусловие (1) и цикл с параметром (2)...
Rin1111
16.03.2020 21:49
Номер 3 или 4А если не трудно, то 3 и 4...
вопросник45
16.03.2020 21:51
Значение массива А [1..100] задаются с фрагмента программы for n:= 1 to 100 do. A [n]:= 100-nСколько элементов массива А будут иметь положительные значения (расписать подробно)...
Популярные вопросы
Большее основание равнобокой трапеции на 16см больше меньшего основания, высота...
1
Составьте электронный баланс к уравнению реакции оксида серы lv с кислородом...
1
1. Перевести смешанное число из десятичной системы в q-ичную: а) q = 6; число...
2
Обчисліть об єм, кількість речовини і число атомів для 20 Г гелію...
2
Андрій Кокотюха. Таємниці козацького скарбу. розділи 1-10. Придумати назву розділам...
1
Какой может быть натуральный мед, его показать..? ...
3
Отметьте на числовой окружности числа. П/2; 3П/2; 2П; 16П/3; -2П/3; 0; П/4; 3П/4;...
1
На скільки градусів підніметься температура сталевої деталі масою 10 кг, якщо...
1
Существуют ли в данном времени единороги?...
3
Быстрому завоеванию Индии Англией в XVII - XVIII веках...
1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Transform(t->t-4); a.Println
end.
Пример
n= 13
-42 -19 36 37 -26 -28 12 12 40 50 24 -8 5
-46 -23 32 33 -30 -32 8 8 36 46 20 -12 1
var
mass : array [0..10] of integer;
i, b : integer;
begin
b := 10;
randomize;
for i := 1 to b do
begin
mass[i] := random(10, 110);
mass[i] := mass[i] - 4;
writeln(mass[i]);
end;
end.