Написать программу по вычислению 7!, используя цикл с предусловием(1) и использую цикл с параметром (2)

evgeniya64 evgeniya64    2   16.03.2020 21:40    3

Ответы
jon10079595 jon10079595  11.10.2020 23:36

Объяснение:

Программа на питоне

a=1

for i in range(1,8)

a = a*i

ПОКАЗАТЬ ОТВЕТЫ
никак45 никак45  11.10.2020 23:36

C предусловием:

var

 i, y: integer;

begin

 y := 1;

 i := 7;

 while i > 1 do

 begin

   y := y * i;

   i := i - 1;

 end;

 writeln('Цикл с предусловием, факториал равен: ', y);

end.

C параметром:

const n=7;

var

i, s: integer;

begin

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln('Цикл с параметром, факториал равен: ', s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика