8 класс Написать программу в PascalABC.net 3.7.1.:
1.Среди К чисел, которые мы будем вводить с клавиатуры из диапазоне от 50 до 100 найти сумму чисел, которые кратные 2 и 3 и количество чисел, которые НЕ кратны 2 и 3.

2.Напишите программу, которая вводит N произвольных чисел и находит количество и сумму четных чисел.

malinka140117 malinka140117    3   14.05.2021 18:17    3

Ответы
ХПолинаХ ХПолинаХ  13.06.2021 18:18

Задание 1)

var

  k,i,s,s2 : integer;

begin

  s:=0; s2:=0;

  for i:=50 to 100 do

     begin

 write('k - ', i, ' = '); read(k);

 if (k mod 2 = 0) or (k mod 3 = 0) then

    s:=s+k;

 if (k mod 2 <> 0) or (k mod 3 <> 0) then

    s2:=s2+k;

     end;

  writeln('Сумма кратных 2 и 3 = ', s);

  writeln('Сумма не кратных 2 и 3 = ', s2);

end.

Объяснение:

Инициализируем переменные, запускаем цикл от 50 до 100, считываем значение k и проверяем кратно ли оно 2 и 3, или нет. Если да - складываем с переменной s. Если нет - с переменной s2. Выводим суммы чисел.

Задание 2)

var

  n,s,r,x,i : integer;

begin

  r:=0;

  s:=0;

  write('n = '); read(n);

  for i:=1 to n do

     begin

 readln(x);

 if x mod 2 = 0 then

    begin

       s:=s+x;

       r:=r+1;

    end;

     end;

  writeln('Сумма четных чисел: ', s);

  writeln('Колличество четных чисел: ', r);

end.

Объяснение:

Инициализируем переменные, считываем N, запускаем цикл от 1 до n.

Считываем в цикле значение x и проверяем четное ли оно. Если да - складываем его сумму и считаем сколько их (Переменные s и r). Затем выводим их.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика