4. составить программу для решения следующей . (уровень а): даны катеты прямоугольного треугольника a и b. найти его площадь s=½*a*b. (уровень b): дано целое число. если оно кратно 3, то удвоить его. в противном случае уменьшить его на величину остатка отделения этого числа на 3. вывести полученное число. (уровень c): найти сумму положительных нечетных чисел, меньших 100.

катя4842 катя4842    3   21.09.2019 16:30    6

Ответы
COYOT61 COYOT61  08.10.2020 07:31
Реализация на с++

Уровень А
#include<iostream.h>

using namespace std;

int main(){
  int a,b;
  cin >>a >> b;
  double s = 0.5 * a * b;
  cout << s << endl;
  return 0;
}
Уровень B
#include<iostream.h>

using namespace std;

int main(){
  int n;
  cin >> n;
  (n%3==0) ? n*2 : n+n%3;
  cout << n << endl;
  return 0;
}
Уровень C
#include<iostream.h>

using namespace std;

int main(){
  int summa = 0;
  for(int i = 1; i < 100; i+=2){
     summa += i;
  }
  cout << summa << endl;
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика