3. Напишите программу, реализующую заполнение случайными числами 20 элементов массива D и вывод их на экран. Элементы массива – это целые числа из промежутка [0;35].
4. Дан одномерный массив В, размерностью 10. Элементы массива – это целые числа из промежутка [0;100]. Напишите программу, вычисляющую сумму элементов массива, которые больше 8 и кратны 12.
Язык программирования Паскаль

Кндр15 Кндр15    1   16.04.2020 10:18    157

Ответы
Glebforst Glebforst  28.12.2023 13:07
Хорошо, я помогу вам решить задачи.

Задача 3:

Для начала, создадим массив D размером 20 элементов и заполним его случайными числами из промежутка [0;35]. Затем выведем содержимое массива на экран.

1. Перед решением задачи нужно скомпилировать и запустить программу с языком программирования Паскаль.
2. Создайте переменную "D" типа массив целых чисел размером 20.
3. Задайте итеративную переменную "i" от 0 до 19 включительно.
4. Внутри цикла, сгенерируйте случайное число "randomNumber" между 0 и 35 (включительно) с помощью функции random.
5. Присвойте сгенерированное число "randomNumber" элементу массива D с индексом "i".
6. Завершите цикл.
7. Создайте переменную "i" типа целого числа и задайте ей значение 0.
8. Внутри цикла, выведите на экран значение элемента массива D с индексом "i".
9. Увеличьте значение переменной "i" на 1.
10. Повторите шаги 8-9 до тех пор, пока "i" не станет равно 19.
11. Завершите цикл.

Пример кода на языке Паскаль:

program RandomArray;
var
D: array[0..19] of integer;
i: integer;
randomNumber: integer;
begin
randomize; // инициализация генератора случайных чисел
for i := 0 to 19 do
begin
randomNumber := random(36); // генерация случайного числа от 0 до 35
D[i] := randomNumber; // присваивание случайного числа элементу массива D
end;

for i := 0 to 19 do
begin
writeln(D[i]); // вывод элемента массива D на экран
end;
end.

Задача 4:

Теперь перейдем ко второй задаче.

1. Создадим массив В размером 10 элементов и заполним его случайными числами из промежутка [0;100].
2. Вычислим сумму элементов массива В, которые больше 8 и кратны 12.
3. Выведем результат на экран.

Мы можем использовать тот же код для генерации случайных чисел и заполнения массива, что и в предыдущей задаче. Однако, для вычисления суммы, добавим условие проверки элементов массива В на соответствие требованиям: быть больше 8 и кратным 12.

Пример кода на языке Паскаль:

program SumOfElements;
var
B: array[0..9] of integer;
i, sum: integer;
randomNumber: integer;
begin
randomize; // инициализация генератора случайных чисел
sum := 0; // инициализация переменной суммы
for i := 0 to 9 do
begin
randomNumber := random(101); // генерация случайного числа от 0 до 100
B[i] := randomNumber; // присваивание случайного числа элементу массива B
if (B[i] > 8) and (B[i] mod 12 = 0) then // проверка соответствия требованиям
sum := sum + B[i]; // добавление элемента к сумме
end;

writeln('Сумма элементов массива B, больших 8 и кратных 12: ', sum); // вывод результата на экран
end.

Надеюсь, что эти пошаговые решения помогут вам понять и выполнить задачи! Если у вас возникнут вопросы, не стесняйтесь задавать их. Удачи вам!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика