1) Задача №112294. Три минимума Напишите программу, которая находит в массиве три минимальных элемента, то есть три первых элемента массива после сортировки по возрастанию.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 3 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке три минимальных элемента массива в порядке возрастания, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 0 5
выходные данные
0 1 2
2)
Задача №112296. Самая длинная цепочка
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки. Если в массиве есть несколько цепочек максимальной длины, нужно вывести данные по первой из них.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 3 < N ≤ 10000 .

Выходные данные
Программа должна вывести два числа через пробел: значение элемента массива, который встречается наибольшее число раз подряд, и длину этой цепочки.

Примеры
входные данные
7
1 2 2 1 1 1 3
выходные данные
1 3
3)
Задача №112298. Реверс половин
Реверс массива – это перестановка элементов в обратном порядке: меняются местами первый и последний элементы, второй и предпоследний и т.д. Напишите программу, которая выполняет реверс двух половин массива по отдельности.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 и N – чётное число.

Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
3 2 1 6 5 4
4)
Задача №112308. Каждый третий
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
1 4
ВСЕ ДЕЛАТЬ НА С++

egor44rus egor44rus    2   22.02.2021 07:08    112

Ответы
1шрус220 1шрус220  22.02.2021 07:10

3 < N ≤ 10000 .

Объяснение:

1 2 3 4 0 5

ПОКАЗАТЬ ОТВЕТЫ
хранитель7 хранитель7  15.01.2024 17:38
Хорошо, я распишу решение каждой задачи по порядку, исходя из условия.
1) Задача №112294. Три минимума
Для решения этой задачи мы будем использовать сортировку элементов массива и выбор первых трех элементов после сортировки. Вот пошаговое решение:

- Читаем размер массива N с помощью функции cin >> N.
- Создаем массив размером N и читаем его элементы с помощью цикла: for (int i = 0; i < N; i++), cin >> array[i];
- Сортируем элементы массива по возрастанию с помощью функции sort(array, array + N).
- Выводим первые три элемента отсортированного массива: cout << array[0] << " " << array[1] << " " << array[2] << endl.

2) Задача №112296. Самая длинная цепочка
Для решения этой задачи мы будем использовать цикл для подсчета последовательных одинаковых элементов и переменные для хранения значения элемента и максимальной длины цепочки. Вот пошаговое решение:

- Читаем размер массива N с помощью функции cin >> N.
- Создаем массив размером N и читаем его элементы с помощью цикла: for (int i = 0; i < N; i++), cin >> array[i];
- Инициализируем переменные max_length = 1 (длина текущей цепочки элементов) и max_element = array[0] (значение элемента в текущей цепочке).
- Запускаем цикл, который будет проходить по всем элементам массива, начиная со второго элемента: for (int i = 1; i < N; i++).
- Если текущий элемент равен предыдущему элементу, увеличиваем max_length на 1.
- Иначе, если max_length больше предыдущей максимальной длины цепочки, обновляем max_length и max_element соответствующими значениями.
- Сбрасываем max_length в 1 для начала новой цепочки.
- После окончания цикла проверяем, если max_length больше предыдущей максимальной длины цепочки, обновляем max_length и max_element соответствующими значениями.
- Выводим значения max_element и max_length.

3) Задача №112298. Реверс половин
Для решения этой задачи мы разделим массив на две половины и поменяем элементы местами. Вот пошаговое решение:

- Читаем размер массива N с помощью функции cin >> N.
- Создаем массив размером N и читаем его элементы с помощью цикла: for (int i = 0; i < N; i++), cin >> array[i];
- Разделяем массив на две половины, используя переменную half = N / 2.
- Запускаем цикл for (int i = 0; i < half; i++), который будет проходиться по половине массива:
- Меняем местами элементы array[i] и array[N - i - 1].
- Выводим все элементы массива: for (int i = 0; i < N; i++), cout << array[i] << " ".

4) Задача №112308. Каждый третий
Для решения этой задачи мы будем использовать цикл, который будет проходить по исходному массиву и выбирать каждый третий элемент. Вот пошаговое решение:

- Читаем размер массива N с помощью функции cin >> N.
- Создаем массив размером N и читаем его элементы с помощью цикла: for (int i = 0; i < N; i++), cin >> array[i];
- Запускаем цикл, который будет проходить по исходному массиву с шагом 3: for (int i = 0; i < N; i += 3).
- Выводим текущий элемент array[i].
- Завершаем программу.

Вот подробные пошаговые решения для каждой задачи. Они написаны на языке программирования C++. Если у тебя есть дополнительные вопросы или что-то не понятно, пожалуйста, дай знать.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика