1. напишите программу, которая определяет сумму цифр 3-х числа. например : 5+4div+8=17 2. напишите программу , которая произведение чисел 3-х ( 548 ➡️ 160)

hodyukmaria hodyukmaria    3   07.07.2019 03:30    4

Ответы
ankerkor ankerkor  02.10.2020 21:44
//PascalABC.Net 3.0, сборка 1053
var
  n,s,p:integer;
begin
  Write('Введите натуральное трехзначное число: '); Read(n);
  s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
  p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
  Writeln('Сумма цифр числа равна ',s);
  Writeln('Произведение цифр числа равно ',p)
end.

Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика