Написать программу на языке C++: Даны катеты двух прямоугольных треугольников a1;b1 и a2;b2. У какого из двух треугольников больше периметр (гипотенуза c^2=a^2+b^2).


Написать программу на языке C++: Даны катеты двух прямоугольных треугольников a1;b1 и a2;b2. У како

Nina2111 Nina2111    1   20.06.2020 17:58    21

Ответы
R1net1 R1net1  15.10.2020 14:32

Объяснение:

#include <bits/stdc++.h>

using namespace std;

int bigger_P(int a, int b, int c, int d)

{

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))>c+d+sqrt(pow(c, 2)+pow(d, 2)))return 1;

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))<c+d+sqrt(pow(c, 2)+pow(d, 2)))return 0;

   return -1;

}

int main()

{

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   int a, b, c, d;

   cin>>a>>b>>c>>d;

   if(bigger_P(a, b, c, d)==1)cout<<"First perimetr is bigger.";

   if(bigger_P(a, b, c, d)==0)cout<<"Second perimetr is bigger.";

   if(bigger_P(a, b, c, d)==-1)cout<<"They are equal.";

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика