1.написать программу, которая вычисляет частное двух чисел. программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), вы давать сообщение об ошибке. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление частного. введите в одной строке делимое и делитель, затем нажмите . -> 12 о вы ошиблись. делитель не должен быть равен нулю.

Фокс890 Фокс890    3   31.05.2019 16:10    7

Ответы
05Goryanka05 05Goryanka05  02.07.2020 01:23
Program qq;
Var a, b, c:real;
Begin
Writeln('введите два числа');
Readln(a,b);
If b=0 then begin writeln('делитель не должен равняться нулю, введите числа повторно')
readln(a, b);
End
If else begin c:=a/b;
End
Writeln('получившееся число', c)
End.
Может где-нибудь есть косячок, но в основном, все должно получиться, удачи:)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика