1)написать программу, которая определяет четной или нечетной является сумма чисел вводимого трехзначного числа.(учитель подсказал, что решается через if xmod=0) решите так, чтобы программа была решена не абы-как, а написана правильно и верно, чтобы программа паскаль читала ее на уроке.2)написать программу вычисления факториала числа. (типа 5! =1*2*3*4*5) заранее .

cheri228 cheri228    3   23.06.2019 03:30    1

Ответы
ALEXDEMI777 ALEXDEMI777  02.10.2020 09:10
№1
var chislo, sum: integer;
begin
repeat
writeln('Введите трехзначное число:');
readln(chislo);
until chislo in [100..999];

while chislo > 0 do
begin
sum := sum + chislo mod 10;
chislo := chislo div 10;
end;

if sum mod 2 = 0 then
write('Число четное')
else write('Число нечетное');
readln;

end.

№2

var factorial: longint; chislo, i: byte;
begin

chislo := 5;
factorial := 1;
for i := 2 to chislo do
factorial := factorial * i;
writeln('5! = ', factorial);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика