(желательно с пояснением) 1. запишите на языке паскаль массив с, в котором 7 элементов, заданных оператором присваивания. вывод в столбик. 2. создать одномерный массив c из 12 целых элементов. числа вводит пользователь с клавиатуры. вывести на экран массив в виде строки чисел. 3. напишите программу, реализующую заполнение случайными числами 15 элементов массива s и вывод их на экран. элементы массива – это целые числа из промежутка [0; 40]. 4. напишите программу, реализующую заполнение 25 числами массива b по формуле и вывод их на экран в строку по формату: целая часть – 9 позиций, дробная – 3 позиции. формула: элемент массива равен сумме двух предыдущих элементов, деленной на номер текущего элемента, т.е. третий элемент равен (первому + второму)/3(индекс третьего) и т.д. значения первого и второго элемента: b[1]: =3; b[2]: =6;

adam80 adam80    3   24.09.2019 08:40    1

Ответы
bitievru2014 bitievru2014  08.10.2020 14:37
1. var
a:array[1..7] of integer;
i:Integer;
begin
//заполнение массива
a[1]:=3;
a[2]:=8;
a[3]:=2;
a[4]:=0;
a[5]:=2;
a[6]:=1;
a[7]:=7;
//вывод массива
for i:=1 to 7 do
Writeln(a[i]);
end.

2. var
c:array[1..12] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 12 do
begin
Writeln('Введите ',i,' элемент массива');
readln(c[i]);
end;
//вывод массива
Writeln('Массив');
for i:=1 to 12 do
Write(c[i],' ');
end.

3.var
s:array[1..15] of integer;
i:Integer;
begin
//заполнение массива
for i:=1 to 15 do
s[i]:=random(40);
//вывод массива
Writeln('Массив');
for i:=1 to 15 do
Write(s[i],' ');
end.

4.var
b:array[1..25] of Real;
i:Integer;
begin
//заполнение массива
b[1]:=3;
b[2]:=6;
for i:=3 to 25 do
b[i]:=(b[i-1]+b[i-2])/i;
//вывод массива
Writeln('Массив');
for i:=1 to 25 do
Write(b[i]:9:3);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика