Free pascal. написать программу детектирования слова-полиндрома

mishany111222333444 mishany111222333444    1   03.09.2019 10:50    5

Ответы
QwErTyля QwErTyля  06.10.2020 14:32
Написал я Вам программу, у себя проверил - работает, думаю и у вас должно.

Program Palindrome_or_not;

var
s: string;
i,f: byte;
begin
write('Введите слово: ');
readln(s);
f := 0;
for i := 1 to length(s) div 2 do
if s[i] <> s[length(s)-i+1] then begin
writeln('Введённое слово не является палиндромом');
f := 1;
break
end;
if f = 0 then
write('Введённое слово является палиндромом');
end.

Надеюсь удачи :)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика