tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Заполнить одномерный массив случайными
Заполнить одномерный массив случайными числами в диапазоне от -10 до 10. вычислите произведение отрицательных элементов массива
Portée
3 07.09.2019 14:30
5
Ответы
bondarantona
03.08.2020 21:27
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
Writeln('П=',a.Where(x->x<0).Aggregate(BigInteger(1),(x,y)->x*y))
end.
Пример
n= 15
-9 1 -6 -2 -9 4 5 -1 6 -6 6 -4 0 5 -10
П=233280
n= 100
4 5 10 -2 9 3 0 7 -2 1 9 -1 -1 -5 -7 5 -4 -6 7 4 -5 10 6 -1 1 -4 -2 5 -6 -10 0 0 -7 -1 -1 7 -6 -1 -3 4 3 -9 7 7 0 -5 7 1 -8 -1 9 6 1 9 6 5 9 1 7 2 -6 6 2 -2 -10 -2 -4 10 6 -3 0 7 8 -8 -10 -7 -7 10 10 -4 0 8 3 6 -8 5 10 -6 4 4 8 4 2 5 -1 8 0 -2 6 -9
П=14271704784175104000000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
nastya2740
31.07.2019 16:30
C++ напишите программу, которая запрашивает два целых числа x и y, после чего вычисляет и выводит значение x в степени y....
gushagusha
31.07.2019 16:30
Спо паскалю 1.задана матрица размером nxm вещественных чисел. получить массив b, присвоив его k-му элементу сумму элементов к 1-й строки матрицы. 2.дан текст, который состоит...
djonli1
29.05.2019 18:30
Как в worde 2013 настроить проверку пунктуации?...
29.05.2019 18:30
Найти количество положительных и отрицательных элементов в одномерном массиве....
BYHOY
29.05.2019 18:30
Даны два множества х=( 12,35,41,53,96) и y(21,41,96,57). найти их объединение и разность....
alisavakhnina1
29.05.2019 18:40
Известны оценки по каждого ученика класса. определить количество пятерок и количество двоек.без использования массива...
Gazizianov2018
29.05.2019 18:40
Нужно написать программу, определяющую минимальное число палиндром, больше n....
xxsPiRiTxx
29.05.2019 18:40
1.дана вещественная матрица размерности n * m. удалить k столбец матрицы....
artem0395
29.05.2019 18:40
Турбо паскаль: for i: =2 to sqrt(n) do if (n mod i = 0) then prost: =0; паскаль выдает ошибку 39 ( в выделеном месте подскажите, как ее устранить...
03721
29.05.2019 18:40
Разработать программу, которая формирует файл f1, содержащий целые числа, и переписывает этот файл в другой файл – f2, помещая в него из f1 только положительные числа.(в паскале)...
Популярные вопросы
Вычислите -3целых 1 седьмая - (-3целых 1/7)...
2
Реши с уравнения! у 2 ящиках было поровну яблок. когда с 1 ящика взяли...
3
По падежам на казахском слово кепіл...
2
На первой полке на 40 книг больше, чем на второй. с первой полки переложили...
2
Укажите ошибку в определении групп союзов по значению 1)соединительные...
2
Найдите, , тест по 9 класс тест 52 реформа политической системы; цели,...
1
Тригонометрия. 1) 2*корень из 2*sin13п/8 *cos12п/8 = 2) корень из 27*cos^2...
3
Один поезд был в пути 13часов, второй 15 часов. они ехали с одинаковой...
2
Что волшебного, а что реального в сказе бажова медной горы хозяйка ? ,...
3
Значение картофеля в жизни человека...
1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
Writeln('П=',a.Where(x->x<0).Aggregate(BigInteger(1),(x,y)->x*y))
end.
Пример
n= 15
-9 1 -6 -2 -9 4 5 -1 6 -6 6 -4 0 5 -10
П=233280
n= 100
4 5 10 -2 9 3 0 7 -2 1 9 -1 -1 -5 -7 5 -4 -6 7 4 -5 10 6 -1 1 -4 -2 5 -6 -10 0 0 -7 -1 -1 7 -6 -1 -3 4 3 -9 7 7 0 -5 7 1 -8 -1 9 6 1 9 6 5 9 1 7 2 -6 6 2 -2 -10 -2 -4 10 6 -3 0 7 8 -8 -10 -7 -7 10 10 -4 0 8 3 6 -8 5 10 -6 4 4 8 4 2 5 -1 8 0 -2 6 -9
П=14271704784175104000000