tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Записать программу для нахождения
Записать программу для нахождения квадрата числа,если оно положительно
polina030502
1 16.08.2019 08:00
2
Ответы
Sweet572
04.10.2020 22:32
#include <iostream>
using namespace std;
int SqrPos(int n);
int main() {
cout << "n=";
int n; cin >> n;
cout << "n^2=" << SqrPos(n) << '\n';
return 0;
}
int SqrPos(int n) {
return (n > 0 ? n * n : 0);
}
ПОКАЗАТЬ ОТВЕТЫ
мия59
04.10.2020 22:32
// PascalABC.NET 3.2, сборка 1356
begin
var n := ReadInteger('Введите число:');
if n > 0 then n *= n else n := 0;
Write('ответ: ', n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
leramailvorob
20.09.2019 15:50
Напишите программу 1) 1: 5=а в квадрате 2)2: 5=d в квадрате: 2...
strelecky
20.09.2019 15:50
Дана точка в с координатами x,y . определить , в какой четверти координатной плоскости лежит данная точка в . точка с координатами ( -5; 5) строчно надо соч за 3 четверть...
rybakovjaroslav
25.12.2020 17:19
найти ответы на вопросы. На каждый вопрос нужен более менее развернутый ответ (6 и более строк). Если нужно могу кинуть на киви (в зависимости сколько скинете ответов)58....
Lolla20031999
25.12.2020 17:17
Сколько равно девяти в двузначной системе...
djhvh235
30.04.2020 21:17
Число Х в шестнадцатеричной системе счисления оканчивается на 8, а в восьмеричной системе счисления - трехзначное число и начинается на 35. Укажите это число в десятичной...
Eugene1000
30.04.2020 21:17
Как называется единицы измерения информации соответствует 2^10 байтах ...
Gsjhcf
22.08.2019 00:10
Кустройствам ввода графической информации относится а)принтер,б)монитор,в)мышь,г)видеокарта...
shopiakprod
22.08.2019 00:10
1)определите значение переменной c после использования данного алгоритма: a: = 25; b: = a-a/5; c: = a*2-b*2; b: = (c/2)^2; c: = 2*b-a; порядок действий соответствует...
16nastia16
22.08.2019 00:10
Примеры ситуаций в которых имеют место линейные, разветвляющиеся и циклические алгоритмы...
Oliichka
22.08.2019 00:00
Емкость какого носителя информации наибольшая? 1)cd диск 2)dvd диск 3)жесткий диск 4) флешка...
Популярные вопросы
По языку 6 класс определить склонение, род, число, падеж и можно где...
1
Составьте хим. формулы соединений серы (-2) с: 1) алюминий 2) кальций...
2
Представьте в виде многочленов (2 + х)3...
2
Представьте в виде многочленов (2 + х)3...
2
Заряд равный 1мкл взаимодействует с зарядом равным 10нкл с силой 9-10^-3н...
2
Представьте в виде многочленов (2 + х)3...
3
Решите : найти объем метана (сн4), если его масса 64г найти массу...
3
Представьте в виде многочленов (2 + х)3...
1
За 3 часа художник расписал 4 вазы сколько времени ему потребуется...
3
Какое однакоренное слово к слову объехал с другой приставкой...
3
using namespace std;
int SqrPos(int n);
int main() {
cout << "n=";
int n; cin >> n;
cout << "n^2=" << SqrPos(n) << '\n';
return 0;
}
int SqrPos(int n) {
return (n > 0 ? n * n : 0);
}
begin
var n := ReadInteger('Введите число:');
if n > 0 then n *= n else n := 0;
Write('ответ: ', n);
end.