Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные

VaDiMiR3000 VaDiMiR3000    2   06.09.2019 02:40    4

Ответы
ramoxa ramoxa  06.10.2020 20:30
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите двухзначное натуральное число:');
  if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
  else Writeln('Нет')
end.

Пример
Введите двухзначное натуральное число: 28
Да
ПОКАЗАТЬ ОТВЕТЫ
228465 228465  06.10.2020 20:30
Program oddn;
var
a,b,c: integer;

begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика