tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Задан одномерный массив
Задан одномерный массив из n чисел. сосчитать: сумму,произведение и среднее арифметическое всех элементов массива
tatiana342
2 15.09.2019 12:40
4
Ответы
cvthidok
07.10.2020 17:11
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018
//Внимание! Если программа не работает, обновите версию!
begin
var N:=readinteger('Введите N=');
var mas:=ArrRandom(N,-99,99); mas.Println;
Writeln('суммa=',mas.Sum);
Writeln('среднее арифметическое=',mas.Average);
Writeln('произведение=',mas.Aggregate(biginteger(1),(x,y)->x*y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ddonor89
27.11.2021 19:54
В EXCEL ПОДРОБНО С РЕШЕНИЕМ, желательно прикрепить файл...
idiotizROSSII
27.11.2021 19:54
В окне Проводник отсутствуют Панели инструментов, чтобы их сделать видимыми надо A) выполнить Сервис - Параметры, в появившемся окне включить опции Панели инструментов...
kjhfdklffsjsw
27.11.2021 19:55
BIOS:life below что это такой??? Хэлп ми сейчас вам большое...
Kotvo4cah
27.11.2021 19:55
Код С++. Ввести пять наборов сторон треугольника а, b, c и определить для каких сторон высота a h будет наибольшей....
Olga6491
27.11.2021 19:59
Установите соответствие между циклами на языке Python? Цикл с постусловием: for i in range (4): k = random () while True: i = i + 1 while i 5: i = i + 1...
usenov7777
03.08.2019 08:40
Дана книге, содержащая 500 страниц. на каждой странице книги 20 строк по 64 символа. какой объём будет занимать книга в кодировке ascii ?...
апро27
03.08.2019 08:40
Имеется сообщение объемом 2 23 бит. какой объём займёт это сообщение в мегабайтах?...
goooll
26.12.2020 13:21
Як захистити елементи керування в шаблоні від вилучення в документі...
boykodiana57
26.12.2020 13:21
Написать программу в Паскале очень надо) Найти среднее арифметическое максимального и минимального элементов массива...
missisvereshac
26.12.2020 13:17
Какие группы операций входят в систему команд любого процессора?...
Популярные вопросы
Решить уравнение 8/3: {[(3,72 - 0,02х)*10/37]: 5/6 +2,8 } -...
1
Яподъезжал уже к москве,когда внезапный вихрь закрутил и погнал...
3
Два колеса соединены ремнем, окружность первого колеса 35 см,а...
1
9. умение изготавливать орудия труда древнейшему че¬ловеку:...
1
могу , написать небольшое эссе по . напишите вот сюда вк/id354409159...
3
Как правильно - в лесу живут 21 медведь? или медведей...
2
За неделю собрали 6500 кг винограда, из которых 650 кг передали...
1
Евгений онегин. какие вечные общечеловеческие проблемы прозвучали...
1
Проверьте ! и я не понимаю где нужен артикль (a) , а где не...
1
Выполни морфологический разбор слова туман...
3
//Внимание! Если программа не работает, обновите версию!
begin
var N:=readinteger('Введите N=');
var mas:=ArrRandom(N,-99,99); mas.Println;
Writeln('суммa=',mas.Sum);
Writeln('среднее арифметическое=',mas.Average);
Writeln('произведение=',mas.Aggregate(biginteger(1),(x,y)->x*y));
end.