Написать программу в Паскале очень надо) Найти среднее арифметическое максимального и минимального элементов массива

boykodiana57 boykodiana57    3   26.12.2020 13:21    5

Ответы
крис903 крис903  25.01.2021 13:24

См объяснение + скриншот.

Объяснение:

program prog;

var

  a:array[1..5] of integer;

  max,min,i:integer;

  srednee:real;

begin

writeln('Zapolnim massiv iz 5 elementov:');

for i:=1 to 5 do readln(a[i]);

max:=a[1];

min:=a[1];

for i:=2 to 5 do begin

 if max<a[i] then max:=a[i];

end;

for i:=2 to 5 do begin

 if min>a[i] then min:=a[i];

end;

writeln('max=',max);

writeln('min=',min);

srednee:=(max+min)/2;

writeln('srednee arifm=',srednee);

end.


Написать программу в Паскале очень надо) Найти среднее арифметическое максимального и минимального э
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика