Задачи на списки в Python: 1. Тре­бо­ва­лось на­пи­сать про­грам­му, при вы­пол­не­нии ко­то­рой с кла­ви­а­ту­ры вво­дит­ся по­сле­до­ва­тель­ность из шести не­от­ри­ца­тель­ных целых чисел, не пре­вы­ша­ю­щих 10^6, под­счи­ты­ва­ет­ся и вы­во­дит­ся сумма введённых чётных чисел или 0, если чётных чисел в по­сле­до­ва­тель­но­сти нет.
2. Тре­бо­ва­лось на­пи­сать про­грам­му, при вы­пол­не­нии ко­то­рой с кла­ви­а­ту­ры вво­дит­ся по­сле­до­ва­тель­ность из шести не­от­ри­ца­тель­ных целых чисел, не пре­вы­ша­ю­щих 10^6, под­счи­ты­ва­ет­ся и вы­во­дит­ся сумма введённых чётных чисел или 0, если чётных чисел в по­сле­до­ва­тель­но­сти нет.
2. На обработку поступает последовательность из четырёх неотрицательных целых чисел (некоторые числа могут быть одинаковыми). Нужно написать программу, которая выводит на экран количество чётных чисел в исходной последовательности и максимальное чётное число. Если чётных чисел нет, требуется на экран вывести «NO». Известно, что вводимые числа не превышают 1000.

neumnaya4044 neumnaya4044    2   10.12.2020 16:17    6

Ответы
TheLoneRider TheLoneRider  10.12.2020 16:20

# 1

count = 0

for i in range(6):

   a = int(input())

   if a % 2 == 0:

       count += a

print(count)

# 2

count = 0

for i in range(6):

   a = int(input())

   if a % 2 == 0:

       count += a

print(count)

# 3

count = ""

maximum = 0

for i in range(4):

   a = int(input())

   if a % 2 == 0:

       count += f"{str(a)} "

       if a > maximum:

           maximum = a

if count == "":

   print("NO")

else:

   print(count)

   print(maximum)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика