tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Язык программирования си дана
Язык программирования си дана последовательность a1, вещественных чисел. найти сумму всех элементов, больших заданного числа b
nikita4502
1 25.08.2019 23:30
7
Ответы
irinavlasova
05.10.2020 19:48
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n=10;
int max = 20, min = 10;
float a[n];
float b;
float sum=0;
srand (time(NULL));
for (int i=0; i<n; i++) {
a[i] = (float) rand() / RAND_MAX*(max-min)+min;
printf ("%.2f ", a[i]);
}
printf("\n");
printf("b = ");
scanf("%f",&b);
for (int i = 0; i<n; i++) {
if (a[i] > b) sum+=a[i];
}
printf("sum = %.2f\n", sum);
return 0;
}
Пример:
11.93 14.67 18.25 13.99 14.33 11.68 15.80 17.83 13.61 18.20
b = 15
sum = 70.08
ПОКАЗАТЬ ОТВЕТЫ
kasa0303
05.10.2020 19:48
#include <stdio.h>
int main()
{
float a, b, sum = 0;
int n;
printf("n = ");
scanf("%d", &n);
printf("b = ");
scanf("%f", &b);
for (int i = 1; i <= n; i++)
{
printf("a%d = ", i);
scanf("%f", &a);
if (a > b)
{
sum += a;
}
}
printf("\nответ: %.2f", sum);
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
syipyr
01.09.2019 17:40
Составьте программу, которая из введенного с клавиатуры натурального числа удалит все 5 и 1. например, число 55901815 превратиться в 908....
0000094
09.10.2019 22:59
Рассчитайте максимальную скорость передачи данных по линии связи с шириной полосы пропускания 100 мгц, если мощность сигнала составляет 62 дбм, а мощность шума в линии связи...
belevich031197
09.10.2019 23:05
Решите молю на доп четверть могут оставить1)57( в 7 степени ) = х ( в 9 степени )2) 4362,75( в 8 степени ) = х ( в 16 степени ) 3) t, - 1010,11; 110,1...
жпжрдмдопнулуу
09.10.2019 23:12
Самый лёгкий вопрос(для тех кто разбирается в компьютерах) процессор intel core i5 3450 самая подходящая(лучшая) видеокарта на этот процессор...
katyamalahova47
09.10.2019 23:18
Вычистелите сумму n членов последовательности если n вводиться с клавиатурыязык qbasic...
fenx73
05.04.2020 17:30
VBA В зависимости от суммы вывести единицы измерения копейка, копеек, копейки...
doblesn
05.04.2020 17:28
Код ардуино светодиод с 4 ма режимами(1-й не мигать 2-э светитя 3-й мигать енноэ количество раз 4-й азбука морзе слово сос)...
Эленедмонд
05.04.2020 17:29
К стандартным типам диаграмм в excel относят :: 1)узорная 2) смешанная 3) пирамидальная 4) Круговая ( возможно несколько вариантов ответа)...
2303010
05.04.2020 17:28
Как объявляются массивы в школьном алгоритмическом языке и в Паскале...
стас488
20.10.2020 17:52
Представить числа в памяти компьютера в 8 битной ячейке: 1. В беззнаковой форме положительные числа а) 56 б) 12 в) 120 2. В дополнительном коде отрицательные числа а) -56 б)...
Популярные вопросы
Вычислите количество вешества щелачь калия с массой 112 вычислите массу 6...
2
По пять предложений на каждое время. язык...
2
Утро воздух был чистый и свежий гуси гуси закончили свои долгий путь они...
3
Перевести на язык: если я буду стремиться к этим факторам, то я смогу найти...
1
Всаду посадили 15 роз.астр в 3 раза меньше. а фиалок в 4 раза больше.чем...
2
Расскажи всё, что ты знаешь из былин о великом князе владимире красное солнышко...
1
Определите границы предложений знаками препинания. пришел сентябрь наступила...
1
Древность и старина это то же самое?...
1
Зная , что а-2b = 3, найдите значение выражения : а) 2b-a б)2а-4b в)4b-2a/3...
1
Вспомните и запишите здесь стишок о словах,в которых нет непроизносимой т....
3
#include <stdlib.h>
int main()
{
int n=10;
int max = 20, min = 10;
float a[n];
float b;
float sum=0;
srand (time(NULL));
for (int i=0; i<n; i++) {
a[i] = (float) rand() / RAND_MAX*(max-min)+min;
printf ("%.2f ", a[i]);
}
printf("\n");
printf("b = ");
scanf("%f",&b);
for (int i = 0; i<n; i++) {
if (a[i] > b) sum+=a[i];
}
printf("sum = %.2f\n", sum);
return 0;
}
Пример:
11.93 14.67 18.25 13.99 14.33 11.68 15.80 17.83 13.61 18.20
b = 15
sum = 70.08
int main()
{
float a, b, sum = 0;
int n;
printf("n = ");
scanf("%d", &n);
printf("b = ");
scanf("%f", &b);
for (int i = 1; i <= n; i++)
{
printf("a%d = ", i);
scanf("%f", &a);
if (a > b)
{
sum += a;
}
}
printf("\nответ: %.2f", sum);
return 0;
}