Язык программирования python.
работа со строками, списками и словарями

1. есть список a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]. выведите все

элементы, которые меньше 5.

2. даны списки:

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89];

b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13].

нужно вернуть список, который состоит из элементов, общих для этих

двух списков.

3. напишите программу для слияния нескольких словарей в один.

dict_a = {1: 10, 2: 20}

dict_b = {3: 30, 4: 40}

dict_c = {5: 50, 6: 60}

4. вы принимаете от пользователя последовательность чисел,

разделённых запятой. составьте список и кортеж с этими числами.

5. выведите первый и последний элемент списка.

6. напишите программу, которая принимает в качестве аргумента имя

файла и выводит его расширение. если расширение у файла определить

невозможно, верните строку «unknown file type».

7. при заданном целом числе n посчитайте n + nn + nnn.

8. напишите программу, которая принимает два списка и выводит все

элементы первого, которых нет во втором.

9. сложите цифры целого числа.

10. посчитайте, сколько раз символ встречается в строке.

Аня8785 Аня8785    3   19.01.2020 16:03    172

Ответы
Auyrey03 Auyrey03  11.10.2020 01:46

#1

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89].

for i in a:

   if a < 5:

       print(a)

#2

def f(a, b):  #функция для сливания двух списков

   ab = a + b

   ab.sort()

   return list(dict.fromkeys(ab))

#3

dict_a = {1:10, 2:20}

dict_b = {3:30, 4:40}

dict_c = {5:50, 6:60}

def update(a, b, c):

   a.update(b)

   a.update(c)

update(dict_a, dict_b, dict_c)

#4

array = list(map(int, input().split(",")))

cortex = tuple(array)

#5

array = [] #здесь твой данный список

print(array[0], array[len(array) - 1])

#6

def f(filename):

   try:

       return filename[filename.index(".") + 1:]

   except:

       return "Unknown file type"

#7

n = int(input())

print(n + n ** 2 + n ** 3)

#8

x = list(input())

f = list(input())

print(sorted(set(f) - set(x)))

#9

num = int(input())

print(sum(list(map(int, str(num

#10

string = str(input())

print(string.count('a'))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика