Язык программирования pascal

дано число ch в десятичной системе исчисления. написать программу, которая переводит число в систему исчисления с основанкм m.

технічні умови: программа читает с клавиатуры в первой строке число m (2≤m≤16) , во второй - число ch (0≤ch≤2+109) . программа выводит на экран ответ в виде текстовой строки.

пример:

ввод:

16

1024

вывод:

400

я то программу сделал, она работает(вроде), но на сайте для проверки пишет что не все значения подходят сделать с нуля программу(я сам найду у себя ошибку) или указать в каком месте я ошибся.

моё решение на фото.

Lizzkkaa Lizzkkaa    3   15.11.2019 20:29    1

Ответы
dasha198156 dasha198156  10.10.2020 13:31

const s:string='0123456789ABCDEF';//цифры СС

var n,m,ch:integer;

r:string;

begin

write('Введите число в 10 СС: ');

readln(ch);

write('Введите СС: ');

readln(m);

write('В ',m,' CC число ',ch);

if ch=0 then r:='0' else r:='';

while ch>0 do

begin

r:=s[ch mod m + 1]+r;//берем остаток от деления на CC и эту цифру пишем в начало строки

ch:=ch div m;//берем целое от деления на CC

end;

write(' равно ',r)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика