Вычислить: номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.написать программу в

MashaLipitenko MashaLipitenko    3   21.06.2019 06:10    7

Ответы
Aldatik Aldatik  16.07.2020 20:53
const  n = 5;   var   a: array[1..n] of integer;   i, k: integer;   s: real;   begin   s := 0;   for i := 1 to n do   begin     readln(a[i]);     s := s + a[i];   end;   s := s / n;   writeln('Среднее значение = ', s:0:3);   k := 1;   for i := 2 to n do     if abs(a[k] - s) > abs(a[i] - s) then k := i;     writeln('Индекс элемента: ', k, ' Значение = ', a[k]); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика