Всем . вообщем, вот и к ней необходимо написать программу(pascal). код программы будет ниже.нужно проверить его на ошибки и дать коментарии к коду. если код неправильный подкорректировать. буду признателен. заранее . : дана последовательность из n действительных чисел (n < = 100). написать программу для подсчета суммы этих чисел. код программы: var massiv: array [1..100] of real; sum: real; n,i: integer; begin clrscr; writeln ('введите количество чисел'); readln (n); for i: =1 to n do begin writeln ('введите ',i,'-ое число'); readln (massiv [i]); end; sum: =0; for i: =1 to n do sum: = sum + massiv [i]; writeln ('сумма последовательности равна ', sum: 0: 4); readln; end.

XXL18 XXL18    3   11.07.2019 23:50    2

Ответы
Sagymbekova1 Sagymbekova1  13.08.2020 14:56
Var i,n:integer;
k,k1:real;
begin;
readln(n);
for i:=1 to n do //повторить n раз
begin;             //начало тела цикла
  readln(k1);    //читаем промежуточную переменную
  k:=k+k1;      //прибавляем к общей сумме
end;               //конец тела цикла
writeln('Result:',k);   //вывод общей суммы
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика