Написать программу. дан массив целых чисел состоящий из 10 ячеек. найти произведение чисел больше 15 и вывести на экран.

asovgira asovgira    3   30.08.2019 09:30    1

Ответы
TinoShtrydenberg TinoShtrydenberg  06.10.2020 04:49
Uses Crt;
Const
   N = 10;
Var
   A:array[1..N] of integer;
   i:integer;
   P:real;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
P:=1;
For i:= 1 to N do
    Begin
    A[i]:=random(201)-100;
    Write(' ',A[i]);
    if A[i] > 15 then P:=P*A[i]
    End;
WriteLn;
if P = 1 then Write('В массиве нет чисел больше 15')
else WriteLn('P = ',P);
ReadLn
End.

Пример работы программы:

Исходный массив: -81 -43 -44 -89 47 80 -5 30 97 -39
P = 10941600
ПОКАЗАТЬ ОТВЕТЫ
maricn2102 maricn2102  06.10.2020 04:49
PascalABC.NET:

begin
  var a:=ArrRandom(10,1,30).Println;
  Writeln('P=',a.Where(x->x>15).Aggregate(1.0,(p,x)->p*x))
end.

Пример:
3 10 23 22 4 7 30 24 21 8
P=7650720
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика