Все богом молю написать программу на языке с дано число x. напечатать в порядке возрастания ln(x), 1+|x|, (1+x^2) x p s только не надо как обычно бред писать ради

piiip piiip    1   07.09.2019 13:10    3

Ответы
spirt708ozrmv0 spirt708ozrmv0  20.08.2020 22:58
#include <stdio.h>
#include <math.h>

int main()
{
float x, y1, y2, y3; 
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f  %f  %f", y1,y2,y3);
else printf("%f  %f  %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f  %f  %f", y2,y1,y3);
else printf("%f  %f  %f", y2,y3,y1);
}
else if (y1<y2) printf("%f  %f  %f", y3,y1,y2);
else printf("%f  %f  %f", y3,y2,y1);
return 0;
}

Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика