Вопрос по информатике. написать программу на языке freepascal. дан массив определённой длины, в котором могут быть как положительные, так и отрицательные числа. проинициализировать массив и найти кол-во элементов массива до первого отрицательного и сумму элементов после него

artemka222288 artemka222288    3   26.08.2019 10:30    3

Ответы
dashagorbunova5 dashagorbunova5  05.10.2020 20:47
Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
   S:real;
Begin
Randomize;
ClrScr;
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')
    End;
WriteLn;
i:=1;
k:=0;
While (A[i]>=0)and(i<N) do
   Begin
   k:=k+1;
   i:=i+1
   End;
if A[i]>=0 then k:=k+1;
WriteLn('k = ',k);
S:=0;
For i:= i+1 to N do
    S:=S+A[i];
WriteLn('S = ',S:0:3);
ReadLn
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика