Вгороде bykhovtown требуются программисты. для того, чтобы вакансии с наибольшей заработной платой не остались не востребованными, мэр города составил таблицу, содержащую данные о номере фирмы и заработной плате. так как данные в таблице не найти самую высокую зарплату не так уж и просто. напишите программу, которая выберет для вас лучшую вакансию. входные данные: в первой строке входного файла записано единственное число n, 1< =n< =300000, определяющее количество вакансий. во второй строке, через пробел записаны зарплаты фирм (числа от 1 до 65000). выходные данные: в единственную строку выходного файла необходимо вывести наибольшую заработную плату в списке. входные данные: 5 23 45 12 45000 3200 выходные данные: 45000
a: array[1..300000] of integer;
Begin
read(N);
for i:=1 to N do
read(a[i]);
max := a[1];
for i := 2 to N do
if a[i]>max then begin
max:= a[i];
end;
write(max);
End.