Написать программу в pascal. из предложения вывести слова с заданным количеством слогов.

nn8255241 nn8255241    2   01.07.2019 08:00    3

Ответы
200NaStYa002 200NaStYa002  24.07.2020 17:53
Количество слогов считаем по количеству гласных букв в слове.

Program pr;
uses crt;

var str,s: string; 
a,i,j,len,k,kslog: byte;      

Begin 
Writeln('Введите предложение'); 
readln(str);   
Writeln('Введите кол-во слогов'); 
readln(k);   
Writeln('Слова с ',k,' слогами:'); 
Writeln;   

len:=length(str); 
a:=0; 
kslog:=0; 

for i:=1 to len do     
            Begin           
                   if (str[i] = ' ')   then         
                        Begin         
                           s:=copy(str,i+1,a);                   
                 
                           for j:=1 to length(s) do           
                           Begin             
                           if s[j] in ['А','О','У','Э','Ы','Я','Ё','Ю','Е','И','а','о','у','э','ы','я','ё','ю','е','и'] then                                                    inc(kslog);           
                           end;                           
                   if (k=kslog) then Writeln(s);               
                   kslog:=0;               
                   a:=0;         
                      end         
                   else  a:=a+1;     
             end;           

Writeln;     
Writeln('Для завершения программы нажмите Enter');     
readln;      
end.      
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика