tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вданном массиве чисел найдите
Вданном массиве чисел найдите среднее арифметическое положительных элементов массива. составить программу для pascal abc
Dalishka808
2 21.09.2019 08:10
6
Ответы
maezsa
08.10.2020 06:42
var
arr : array[1..99] of integer;
N, s, k : integer;
begin
read(N);
for var i := 1 to N do begin
arr[i] := random(-10, 10);
writeln(arr[i]);
if arr[i] > 0 then begin
s += arr[i];
k += 1;
end
end;
writeln(s/k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kaliyeva2006amina
08.06.2019 02:10
Водномерном массиве подсчитать количество пар стоящих рядом нечетных элементов....
Daniil2263
08.06.2019 02:10
Запишите на алгоритмическом языке: а)ax² + bx + c б) v + at²/2 в)1/2(a+b)h г)1+x₁x₂/ b²c д)√a²+b²...
DashaL04
26.05.2019 16:25
Можно без решения)) скорость передачи данных через adsl-соединение равна 1024000 бит/с. через данное соединение файл размером 2000 кбайт. определите время передачи...
Sinderella2006
26.05.2019 16:25
Создать консольное приложение на языке c#...
Darya0012
26.05.2019 16:22
Информатика делфивопрос по делфи информатика матрицымне дали по информатике (см фото 18)я нарисовал таблицу, задал изменение колличество строк и столбцов в матрице,...
Leha9202
26.05.2019 16:19
Что характерно для растровой графики выберете один или несколько ответов: 1) изображение масштабируются без потери качества 2) возникает искажение изображений при...
DanProGold
26.05.2019 18:00
Как слово теремок написать в ворде 2010...
pro00losk
26.05.2019 18:00
Составьте программу, которая заменяет все буквы о на символ * в строке s....
fhftufdy12233p01cf0
26.05.2019 18:00
1.составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число положительное. 2. составить программу вывода на экран чисел от...
musalimovvlad
26.05.2019 18:00
2.определите информационный объем звукового файла,если файл длится 1 минуту и звуковой картой с частотой 32 кгц и разрешением 8 бит воспроизводится стереозвук.ответ...
Популярные вопросы
Округлите число 25,99 до целого числа...
2
Пересказ „Васюткино озеро„...
2
прочитать эпизод приготовления глухаря и записать краткий пересказ...
2
Решите уравнения: а) 2-3x=-10 б)-0,8x=-5,6...
3
ВТЕСТЫ ДЛЯ 5 КЛАССА СЛОВООБРАЗОВАНИЕ. 1. Какие два основных...
2
РЕБЯТА ИЗИ Три проволоки одинаковой длины и поперечного сечения,...
3
Даосизмнің негізін салған тұлға * ...
1
Эссе. Почему личная жизнь лучше преуспевании в профессии. Аргументы...
1
Определить выталкивающую силу, действующуу на камень объемом...
2
Как это сделать? Для совокупности 2,3,4,5,6,6,6,7,8,9 составить...
2
arr : array[1..99] of integer;
N, s, k : integer;
begin
read(N);
for var i := 1 to N do begin
arr[i] := random(-10, 10);
writeln(arr[i]);
if arr[i] > 0 then begin
s += arr[i];
k += 1;
end
end;
writeln(s/k);
end.