tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вариант 4 дан массив из n
Вариант 4 дан массив из n чисел (xi). найти максимальный элемент массива (max).
Zzzz151
2 22.09.2019 16:00
3
Ответы
Вова1337228
08.10.2020 09:57
Const
MAX_SIZE = 200;
var
N, Max, i: integer;
X: array [1..MAX_SIZE] of integer;
begin
randomize;
write('N = ');
readln(N);
writeln('Исходный массив: ');
for i := 1 to N do
begin
X[i] := random(101)-50;
write(X[i], ' ');
end;
writeln;
Max := X[1];
for i := 1 to N do
if (X[i] > Max) then
Max := X[i];
writeln('Максимальный элемент массива = ', Max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ya042302SashaA
15.05.2021 14:50
По данным электронной таблице определите чему будет равно значение в ячейке D5?...
кВіТкА9876565446
15.05.2021 14:49
ИНФОРМАТИКА (простое задание) Множество A содержит натуральные числа из отрезка [15..30]. Множество B содержит натуральные числа из отрезка [23..40]. Сколько чисел из множества...
j5022778
15.05.2021 14:47
Если знаете ответ, можете сразу скрин с приложения? Чтобы увидеть, правильно или нет...
5555321
20.06.2019 02:50
Мощность алфавита равна 8. количество информации в сообщении равно 90 бит. вычислить количество информации, приходящееся на один символ сообщения, и количество символов в сообщении....
sasharaiskaja
21.01.2020 22:15
Свойство формы соответствующей ширины формы в пикселях....
Remus1
21.01.2020 22:21
Вчём ошибка? import datetime # step 2 birth_day = int(input( day of birth: )) birth_month = int(input( month of birth: )) birth_year = int(input( year of birth: )) day = int(datetime.date.)...
Виктория54345888
21.01.2020 22:23
Составить блок схему по этим пунктам ...
gasha1234567890
15.10.2019 11:30
Коля изобрёл машину времени у себя в гараже и решил на этом заработать. но так как он знает, что организация контроля времени может забрать у него машину, он решил вести себя...
greentyler451
15.10.2019 11:29
Введіть число - номер дня тижня .виведіть слово-назву цього дня...
kunakovdp06u5r
15.10.2019 11:19
Вприложении clion в messages: build выводит такую ерунду: warning c4018: : ґб®®вўґвбвўёґ вёї®ў б® § є®¬ ё ўґ§ § є как с этим бороться? ? 50 !...
Популярные вопросы
решить уравнение 6^cos2x 6^cos^2x+sinx....
1
Спишіть слова сполучення вставляючи де потрібно,букву н Цін...и подарунок,...
3
Сходство астры и тюльпана Сходство астры и тюльпана...
3
Выбери правильное имя файла: Выберите один ответ: 1. 7A_klass 2. 7 А класс.doc...
2
Рисунку трикутник ANB=трикутнику AMB . Доведи, що трикутник ANC=трикутнику...
3
Эссе на тему переживания Герасима в рассказе Муму.Не меньше 150 слов!...
2
За правильный ответ 40 б 3. Какое количество диоксида углерода при 5.066*10°...
2
Знайдіть відмінності в судинах, якими починається велике коло кровообігу у...
2
Объясните значение выражения выйти с топором по орехи...
1
Эссе на тему новый год (на английском)8-9 предложений...
2
MAX_SIZE = 200;
var
N, Max, i: integer;
X: array [1..MAX_SIZE] of integer;
begin
randomize;
write('N = ');
readln(N);
writeln('Исходный массив: ');
for i := 1 to N do
begin
X[i] := random(101)-50;
write(X[i], ' ');
end;
writeln;
Max := X[1];
for i := 1 to N do
if (X[i] > Max) then
Max := X[i];
writeln('Максимальный элемент массива = ', Max);
end.