Умоляю, с паскалем 1. пользователь вводит неотрицательное однозначное число a. написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом a, вычисляющую в случае ввода 2 - площадь квадрата со стороной a, вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной a, сообщение «нужно ввести число 1, 2, 3» в остальных случаях.

culi42 culi42    3   01.06.2019 17:10    3

Ответы
nurasylmahambet nurasylmahambet  02.07.2020 19:22
1) по заданному радиусу: Program n1;
Uses CRT;
Var r,s: real;
begin
ClrScr;
writeln('Vvedite radius');
readln(r);
s:=r*r*pi;
Writeln('ploshad =',s:4:4);
readln
end. 2) по заданным сторонам:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storoni');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end. 3) по заданной сторонеProgram n1;
Uses CRT;
Var a,s: real;
begin
ClrScr;
writeln('Vvedite storony');
readln(a);
s:=a*a;
Writeln('ploshad =',s:4:4);
readln
end. 3) по одной стороне и высоте к ней:Program n1;
Uses CRT;
Var a,b,s: real;
begin
ClrScr;
writeln('Vvedite storony i vysoty k nei');
readln(a,b);
s:=a*b;
Writeln('ploshad =',s:4:4);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика