tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Тема: pascal, цикл з передумовою;
Тема: pascal, цикл з передумовою; задано ціле число. знайти суму цифр у записі числа.
uraalekseev1234
3 23.07.2019 04:30
1
Ответы
NoName4643
23.09.2020 21:25
//Pascal ABC.NET v3.1 сборка 1172
Var
n,c,s:integer;
begin
read(n);
while n<>0 do
begin
c:=n mod 10;
s:=s+c;
n:=n div 10;
end;
writeln(s);
end.
Пример ввода:
123
Пример вывода:
6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Микарусский
02.09.2020 23:39
Выбери ответ. Сервер — это специальный компьютер, который предназначен для удаленного запуска приложений, обработки запросов на получение информации из баз данных...
winchester24
10.12.2020 15:43
Создайте таблицу в Excel как на фото, с формулами...
daniiltpgatov6
10.12.2020 15:44
Контрольная работа №2 «Элементы алгебры логики»Вариант 1.1)Выпиши номера истинных высказываний:Число 376 четное и трехзначное.Неверно, что Земля вращается вокруг...
FACCE
01.04.2019 05:20
Дана символьная строка всюду букву а поменять на букву в...
kononovadm
24.06.2019 19:48
Найдите наименьшее натуральное число, которое нужно подать на вход алгоритма, чтобы в результате были выведены числа 3 и 7....
tanuabekker00
24.06.2019 20:40
Каковы правила записи (формат) оператора repeat...
messaivi
28.01.2021 20:39
1. Эта девушка сражалась против Англичан во время войны 1337-1453 гг. Впишите её имя. 2. Собрание представителей духовенства, дворянства и городов: штаты. Впишите...
kaznacheev27p070e2
28.01.2021 20:39
Как образуются степени сравнения категории состояния...
grandx04
28.01.2021 20:39
Чему равна средняя скорость vср движения груза на пружине за время одного колебания, если его максимальная скорость v0=0,5 м/с?...
Nastyadavydenko
28.01.2021 20:39
Кто расследовал берельзкий курган ...
Популярные вопросы
З якою силою електричне поле напруженістю 400 Н/Кл діє на заряд...
1
тема: геометрическая прогрессия...
3
10-тапсырма. Ғылым мен технологиялардың дамуы туралы әлеуметтік-мәдени...
1
Прочитайте стихотворение Л. Дерягина «Россия» и выполните задание:Россия...
3
Попробуйте ответить письменно на во по видео-уроку: 1)Where does...
2
Расположите по возрастанию 14 бит, 5 Кбайт, 50000 бит...
2
Найдите все точки М (х;у), для которых /МА/=2 и угол МАВ =120градусов,...
2
ответте Що надає поезія ісая Глава 35 біблійного звучання ? 2Які...
2
Номер кто понимает, ГЕОМЕТРИЯ 11 10 11 КЛАСС...
3
Какая существует закономерность между распределением полезных...
1
Var
n,c,s:integer;
begin
read(n);
while n<>0 do
begin
c:=n mod 10;
s:=s+c;
n:=n div 10;
end;
writeln(s);
end.
Пример ввода:
123
Пример вывода:
6