tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Создать программу языком
Создать программу языком delphi (мне только нужен сам код) визначити за данними сторонами , чи являється трикутник рівностороннім.
Женьочки
2 24.09.2019 15:10
53
Ответы
MrTarelo4ka
08.10.2020 15:36
Program kurs;
{$APPTYPE CONSOLE
Uses SysUtils;
type //раздел описания типов данных
tArray=array [1..20,1..40] of byte; //описание типа двумерного
//массива 20x40 элементов
tArray2=array [1..400] of byte; // описание типа массива из 400
//элементов
var //раздел объявления переменных
A:tArray; //массив с результатами эксперимента
B:tArray2; //сформированный одномерный массив
n, //количество столбцов массива A
m, //количество строк массива A
k:byte; //размер массива B
d:byte; //количество искомых элементов
S:real; //среднее арифметическое элементов массива В
//
// Функция ввода массива. Возвращает размер массива n, m и //введенный массив Z
Function InputArray(var Z:tArray; var m, n:byte):boolean;
var
i,j:byte; // индексные переменные
begin
//вывод сообщения о вводе n
writeln('Введите размер массива n:');
//вводим n
readln(n);
…
end;
//Процедура вывода одномерного массива Y размерностью k
Procedure OutputArray(Y:tArray2; k:byte);
var i:byte; //индекс массива
begin
…
end;
//Процедура создания одномерного массива Y
//из двумерного Х по заданной схеме
Procedure Create(X:tArray; m:byte; n:byte; var Y:tArray2; var k:byte);
var
i, //индекс массива
j:byte; //индекс массива
l,t:byte; //индексы массива
s:set of byte; //множество элементов массива
f:boolean; //флаг наличия схожего элемента
//в нижней части массива
begin
…
end;
end; //конец процедуры
//Процедура поиска среднего арифметического
Function SrZnach(X:tArray2; n:byte):real;
var
i:byte; //индекс массива
Sr:real; //переменная для подсчета среднего арифметического
begin
…
end;
//Процедура подсчета в массиве Х элементов,
//которые отличаются от значения Sr больше чем на 50%.
//Возвращает количество искомых элементов k
Procedure Calc(X:tArray2; n:byte; Sr:real; var k:byte);
var
i:byte; //индексы массива
begin
i:=1; //задаем начальный индекс массива
k:=0;
…
end;
//начало основной программы
begin
…
end. //конец программы
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
BellaNow
29.01.2022 01:53
Доклад на тему поисковые системы...
moaariishkkaa
11.07.2019 01:10
Информатика массивы: как описывается одномерный массив? как происходит обращение к одномерным массивом? как осуществляется ввод и вывод одномерных массивов? какой...
CorjikPlay
11.07.2019 01:10
Задается массив из n натуральных чисел. найти сумму чисел в которых цифры по возрастанию. язык- паскаль. сделать надо через функцию...
rakrak2016
11.07.2019 01:10
Цифры 1234567 между ними надо поставить знаки плюс минус деление умножение скобки что-бы получилась цифра 1...
норрд
11.07.2019 01:10
Program bar; var a,b,c: intenger; begin read(a,b) if a=b then begin c: =(a*b)/2 write(c) end else write(a,b); end. кому не трудно у кого есть программа паскаль введите...
НиколайКот
11.07.2019 01:10
По каналу связи непрерывно в течение 8 минут данные.скорость передачи данных составляет 512 кбит в секунду .сколько кбайт данных было передано за время работы канала?...
аня8960
11.07.2019 01:20
Какова время (в секундах )передачи полного объема данных по каналу связи если известно , что передано 1200 кбайт данный,причем передача шла со скоростью 60 кбит в...
llboyn
11.07.2019 01:20
Составьте программу с клавиатуры которая выводит на экран нечетные числа в диапазоне от 20 до 50...
anton4rf4
11.07.2019 01:20
Возможность восстановления данных с использованием информации с данных других дисков. к какому виду reid это относится?...
nigaic
11.07.2019 01:30
Решить. дана строковая величина i. написать программу, выводящую на экран третью букву и определяющую длину строковой величины i....
Популярные вопросы
До ть будьласка!! Схарактеризуйте білки за такими ознаками: відносна...
2
Расстояние между двумя городами 750 км. Рейсовый автобус проезжает...
2
В какой, по вашему мнению происходило взаимопроникновение культур...
3
Замените прямую речь косвенной. Используйте сложноподчиненные...
2
Ксюша поставила фишку в одну из клеток квадрата 4×4. Она передвигала...
2
1. Определи порядок выполнения действий и вычисли,234 : 2 + 340...
3
Выделите номера предложений, в которых использовано цитирование....
2
Прочитай текст и ответь на во по тексту...
3
11. Запишите ответ на во Кто такой «садовНИК»? из отрыва история...
1
сделать номер 5. условие-решение-ответ чтобы было...
1
{$APPTYPE CONSOLE
Uses SysUtils;
type //раздел описания типов данных
tArray=array [1..20,1..40] of byte; //описание типа двумерного
//массива 20x40 элементов
tArray2=array [1..400] of byte; // описание типа массива из 400
//элементов
var //раздел объявления переменных
A:tArray; //массив с результатами эксперимента
B:tArray2; //сформированный одномерный массив
n, //количество столбцов массива A
m, //количество строк массива A
k:byte; //размер массива B
d:byte; //количество искомых элементов
S:real; //среднее арифметическое элементов массива В
//
// Функция ввода массива. Возвращает размер массива n, m и //введенный массив Z
Function InputArray(var Z:tArray; var m, n:byte):boolean;
var
i,j:byte; // индексные переменные
begin
//вывод сообщения о вводе n
writeln('Введите размер массива n:');
//вводим n
readln(n);
…
end;
//Процедура вывода одномерного массива Y размерностью k
Procedure OutputArray(Y:tArray2; k:byte);
var i:byte; //индекс массива
begin
…
end;
//Процедура создания одномерного массива Y
//из двумерного Х по заданной схеме
Procedure Create(X:tArray; m:byte; n:byte; var Y:tArray2; var k:byte);
var
i, //индекс массива
j:byte; //индекс массива
l,t:byte; //индексы массива
s:set of byte; //множество элементов массива
f:boolean; //флаг наличия схожего элемента
//в нижней части массива
begin
…
end;
end; //конец процедуры
//Процедура поиска среднего арифметического
Function SrZnach(X:tArray2; n:byte):real;
var
i:byte; //индекс массива
Sr:real; //переменная для подсчета среднего арифметического
begin
…
end;
//Процедура подсчета в массиве Х элементов,
//которые отличаются от значения Sr больше чем на 50%.
//Возвращает количество искомых элементов k
Procedure Calc(X:tArray2; n:byte; Sr:real; var k:byte);
var
i:byte; //индексы массива
begin
i:=1; //задаем начальный индекс массива
k:=0;
…
end;
//начало основной программы
begin
…
end. //конец программы