Составьте программу заполнения массива не используя клавиатуру, числами 1, -3, 5, -7, 9, -11, 13, -15. в питоне , если можно то не сильно сложно

MadPrinter MadPrinter    2   08.09.2019 10:10    6

Ответы
Strong996 Strong996  07.10.2020 00:37
# coding: utf-8
list = []  # создаём пустой лист
flag = 0  # переменная, которая будет чередоваться
for i in range(1, 16, 2):  # диапазон от 1 до 15 с шагом в 2 числа
    if flag == 0:  # когда переменная равна 0 пишем положительное число
        list.append(i)
        flag = 1
    else:  # иначе отрицательное
        list.append(-i)
        flag = 0
print(list)  # выводим результат на экран



Первую строку можно не писать.



Код без комментариев:

list = []
flag = 0
for i in range(1, 16, 2):
    if flag == 0:
        list.append(i)
        flag = 1
    else:
        list.append(-i)
        flag = 0
print(list)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика