Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел на среднюю этих чисел help ! please

Triana Triana    1   18.05.2019 03:40    4

Ответы
Partizannn Partizannn  11.06.2020 08:51

program lkcfndsl;

uses crt;

var a,b,s,g:real;

begin

clrscr;

readln(a,b);

s:=(a+b)/2;

g:=sqrt(a*b);

if a>b then a:=g else a:=s;

if b>a then b:=g else b:=s;

writeln(a,b);

readln;

end.

Надеюсь так понял.

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика