Составьте программу,заменяющую из двух данных чисел большее число удвоенным произведением,а меньшее-полусуммой этих чисел.

lolaaaaa2 lolaaaaa2    2   21.05.2019 14:40    4

Ответы
Kseniyak04 Kseniyak04  16.06.2020 00:54

program 1;

 

uses crt;

 

var a,b:real;

begin  clrscr;

 

write('vvedite a '); readln(a);

write('vvedite b '); readln(b);

 

If a>b then begin a:=abs(2*a*b);                   b:=abs((a+b)/2);                   end else begin a:=abs((a+b)/2);                                  b:=abs(2*a*b);                                  end; writeln('a= ',a:0:2,' ','b= ',b:0:2); repeat until KeyPressed; end.

ПОКАЗАТЬ ОТВЕТЫ
1user 1user  16.06.2020 00:54

ну а вдруг числа отрицатильные)) а abs делает их положительными)


var a,b:real;
begin cls;

write('vvedite a '); readln(a);
write('vvedite b '); readln(b);

If a>b then
begin
a:=2*a*b;
b:=(a+b)/2;
end
else
begin
a:=(a+b)/2;
b:=2*a*b;
end; writeln('a= ',a:0:2,' ','b= ',b:0:2);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика