tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
составьте программу
"составьте программу вычисления суммы элементов от первого отрицательного и до конца" (pascal abc)
incest
2 02.06.2019 21:30
7
Ответы
Нармин59
03.07.2020 13:24
Var
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
maksimiksanov
29.03.2021 15:57
, дайте ссылку или ответ. Мне нужна программа которая удаляет или просто выключает компьютер когда флешка с этой программой вставляется в компьютер жертвы...
Xalk22
29.03.2021 15:57
Составить программу для формального исполнителя чертёжник результатом работы которой будет изображение ...
nosalyaik
29.03.2021 16:00
Два поезда выехали одновременно навстречу друг другу. Первый ехал со скоростью 80 км/ч, а второй со скоростью 70 км/ч. Найдите расстояние между этими поездами за...
Vika7791532
29.03.2021 16:03
Напишите программу на Python, которая берет список и возвращает новый список с уникальными элементами первого списка. Пример: Список : [1,2,3,3,3,3,4,5] Полученный...
мадя21
29.03.2021 16:12
3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение...
RedHamster
29.03.2021 16:16
Два поезда выехали одновременно навстречу друг другу. Первый поезд ехал со скоростью 60 км/ч, второй ехал со скоростью 90 км/ч. Найдите расстояние между этими поездами...
ВладыкаМор
29.03.2021 16:19
Найти максимум из пяти введенных чисел Подскажите где тут ошибка понять не могу Последняя задача...
матиматик31
29.03.2021 16:19
Решить задачу в среде VB , если можно, то с блок схемой. В квадратной матрицы 3x3 , заполненной целыми числами, найти количество отрицательных элементов, сумму нечетных...
helpmepls69
29.03.2021 16:25
Значение величины хравно а, значение у равно Б. После выполнения каких из указанных Ниже последовательностей команд значения Хиу поменяются, т. е. x станет равно...
bitvazat
29.03.2021 16:47
Написати програму виведення на екран усіх чисел що лежать між заданими числами N та М....
Популярные вопросы
Замени одну из частей сложного предложения деепричастным оборотом,...
3
Давньоруський ударний інструмент, великий військовий барабан 1)окарина2)кувикли3)тулумбас...
1
М яч кинутий вертикально вгору впав на землю через 5 секунд. На...
1
распустить складання таблица украинских культура конца XVIII Столетия...
2
6. Укажите сложноподчиненное предложение с однородным подчинением...
3
Дано куб АБСДА1 В1С1Д1 ВИЗНАЧИТИ КУТ МІЖ ПРЯМИМИ ВД І А1С1...
3
все эпитеты метафоры и олицетворение из стиха благовещенье в москве...
1
ответьте на вопросы по теме Жаңыл Мырза...
3
4. Першого дня завезли до бібліотеки 7/15 нових книг, а другого...
2
1 When falls, old buildings and monuments can be damaged. 5 One...
1
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.