3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение цифр кратно 3. Например, у числа 23 удвоенное произведение цифр 2*(2*3) = 18, т.е. кратно 3, а у числа 25 удвоенное произведение цифр 2*(2*5) = 20 не кратно 3. Определите, сколько чисел удо-влетворяет задаче

мадя21 мадя21    1   29.03.2021 16:12    4

Ответы
аринашум2007 аринашум2007  28.04.2021 17:11

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int i, kol = 0;;

   for(i = 10; i < 99; i++){

       if( (2 * ((i % 10) * (i /10))) % 3 == 0){

           ++kol;

       }

   }

   cout<<"Количество чисел: "<<kol<<endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика