составьте программу в паскале abs. найти произведение чисел от 1 до n. через цикл while и repeat​

Sonya2308 Sonya2308    2   18.04.2020 06:18    2

Ответы
Школьник5432467 Школьник5432467  13.10.2020 11:08

1. while

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

while i<=n do

begin

p:=p*i;

i:=i+1

end;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

2. repeat

var i,n: integer;

p: real;

begin

write('Введите число: ');//n<171

read(n);

p:=1;

i:=1;

repeat

p:=p*i;

i:=i+1

until i>n;

write ('Произведение чисел от 1 до ',n,' равно ',p)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика