tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу в паскаль
Составьте программу в паскаль с while. у малыша к банок варенья. в первый день карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. через сколько дней варенье кончится?
masha3231
1 17.07.2019 08:20
0
Ответы
dzeratigieva
30.08.2020 19:23
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;
While (K>0) do
Begin
s_el:= s_el * 1.5;
K:=K - s_el;
den:=den+1;
end;
Writeln('Варенье кончится через ', den, ' дней');
readln();
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
KsushaTrefilova
26.01.2020 14:06
Облочние технологии использования в технологии с примерами...
annatokar031
03.06.2019 08:20
Информатика 9 класс .) начальное состояние: исполнитель находится в нижнем правом углу и смотрит вверх. где будет исполнитель после выполнения следующих программ? а) пока...
fil2143878
03.06.2019 08:20
Написать программу в паскале определяющую является ли четырехугольник квадратом...
milka5561
03.06.2019 08:20
Нужна , ! определить значение переменной s после выполнения следующего фрагмента алгоритма, представленного в виде блок-схемы, если а=692. начало: 1) ввод а, 2) s: =0 3) s:...
jimjimkim
03.06.2019 08:20
Что произойдёт если пользователь попытается отправить электронное сообщение,не заполнив поле тема...
Mishgan21
03.06.2019 08:20
Для чего используются в строке поиска кавычки?...
elenarum18
14.09.2021 07:31
Байт,кбайт,мбайт,гбайт дегеніміз не ДА 35Б...
LBVFCBRF
14.09.2021 07:20
Информатика Только второе упражнение! Если что непонятно в коммы пишите...
aaaaaaggghhh
06.12.2020 11:59
В классе 30 человек. Получены следующие результаты педагогического измерения. Рассчитайте числовые характеристики данного распределения (математическое ожидание, выборочную...
Tesckep
06.12.2020 11:55
Выполни исследовательский проект по предложенной теме, указанной ниже. Проект выполни в форме презентации в программе PowerPoint – 5 слайдов. На 1 слайде - Тема проекта (Векторная...
Популярные вопросы
Решить неравенство , содержащие переменную под знаком модуля а) |2x + 3|...
2
Написать рассказ о себе как участник археологической экспидиции...
2
1. на какие вид делятся предложения по цели высказывания?...
1
Трудно угадать каким вырастет ребенок. глагол угадать в каком времени?...
3
По вине заснувшего человека с сигаретой выгорело три квартиры много этажного...
3
Из двух городов навстречу друг другу одновременно выехали автомобиль и...
3
На какой вопрс отвечает слово молчать...
3
На луче h с началом в точке o отложите отрезки oa и ob так, чтобы точка...
1
Выберите и вставьте правильную форму глагола. 1. we to school every day....
1
Площадь ромба равна 50 см крадратных, а один из ее углов 30 градсов. найдите...
3
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;
While (K>0) do
Begin
s_el:= s_el * 1.5;
K:=K - s_el;
den:=den+1;
end;
Writeln('Варенье кончится через ', den, ' дней');
readln();
end.