Составьте программу в паскаль с while. стакан кипятка (100 °с) остыл за первую минуту на а градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. через сколько минут температура воды станет ниже nо с?

alexeyivanovnk1234 alexeyivanovnk1234    2   17.07.2019 08:20    5

Ответы
Рожочек11 Рожочек11  03.10.2020 06:15
Var A, gradus, minut, N: real;
Begin
Writeln('Введите A градусов');
readln(A);
Writeln('До какой температуры остужать:');
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
   A:=A*(1-0.15);
    gradus:=gradus-A;
    minut:=minut+1;
 end;

Writeln('Кипяток остынет до ',N,' градусов через ', minut, ' минут');
readln();
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика