Составьте программу в pascal abc, которая заполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 100 , затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивы

gazelle116 gazelle116    3   11.09.2019 13:20    14

Ответы
ударник4г ударник4г  07.10.2020 07:32
Var
  a: array[1..10] of integer;
  i, max, imax, min, imin: integer;

begin
  Randomize;
  max := 0;min := 101;
  Write('Исходный массив:        ');
  for i := 1 to 10 do
  begin
    a[i] := random(100) + 1;
    Write(a[i], ' ');
  end;
  Writeln();
  For i:= 1 to 10 do begin
   if a[i] > max then
    begin
      max := a[i];
      imax := i;
    end;
    if a[i] < min then
    begin
      min := a[i];
      imin := i;
    end;
  end;
  swap(a[imax], a[imin]);
   Write('Преобразованный массив: ');
   For i:= 1 to 10 do
     Write(a[i], ' ');
   Writeln;
   Write('Я поменял местами ', imax, ' и ', imin, ' элементы');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика